System Requirements

Requirements for Telemetry Service

Software
Version
Node
12x or above
Docker
19.x or above
Kafka
2.4.1

Requirements for Data Pipeline

Software
Version
Java
11
Scala
2.12.x
Apache Flink
1.13.0
Kafka
2.4.1
Redis
5.x or above
Kubernetes
1.17.0 or above

Requirements for Data Service

Software
Version
Java
8
Scala
2.11.x
Docker
19.x or above
Postgres
9.6 or above

Requirements for Report Service

Software
Version
Node
12x or above
Docker
19.x or above
Postgres
9.6 or above

Requirements for Report Configurator

Software
Version
python
3.5 or above
Docker
19.x or above

Requirements for Summarisers

Software
Version
Java
8
Scala
2.11.x
Spark
2.4.4
Kafka
2.4.1

​